Skip to content

Axios denial-of-service vulnerability in Freeform 4.x development dependency

Low
kjmartens published GHSA-58q2-9x27-h2jm Jan 15, 2026

Package

composer solspace/craft-freeform (Composer)

Affected versions

< 4.1.29

Patched versions

4.1.30

Description

Summary

Freeform for Craft CMS included a vulnerable version of Axios affected by CVE-2025-58754 / GHSA-4hjh-wcwx-xvwj. The upstream Axios vulnerability can cause excessive memory allocation when Axios is used in a Node.js environment to process attacker-controlled data: URLs.

Freeform 4.1.30 updates the affected dependency.

In typical Craft CMS production environments, Freeform runs server-side in PHP, not Node.js. As a result, the practical impact to Freeform installations depends on whether the vulnerable Axios code is reachable in a Node.js runtime with attacker-controlled input. No direct unauthenticated Craft/PHP server-side exploit path has been confirmed in Freeform.

Details

Package: solspace/craft-freeform
Dependency: Axios
Upstream advisory: CVE-2025-58754 / GHSA-4hjh-wcwx-xvwj
Patched Freeform version: 4.1.30

Axios versions affected by the upstream advisory may allocate excessive memory when handling large data: URIs in Node.js. This behavior can lead to process memory exhaustion and denial of service when attacker-controlled data: URLs are passed to Axios.

Freeform included an affected Axios dependency prior to the dependency update in Freeform 4.1.30.

Impact

The confirmed issue is the presence of an affected Axios dependency. The upstream vulnerability may allow denial of service in applications that use Axios in a Node.js runtime to process attacker-controlled data: URLs.

For Freeform, the practical risk appears limited unless an installation or customization exposes a Node.js execution path where attacker-controlled URLs are passed to Axios. No direct unauthenticated denial-of-service path in Freeform’s Craft/PHP runtime has been confirmed.

Remediation

Update Freeform to 4.1.30 or later.

Workarounds

If updating immediately is not possible, ensure that any custom code using Axios does not pass attacker-controlled data: URLs to Axios in a Node.js runtime. Where URL fetching is required, validate and restrict allowed URL schemes before making requests.

Severity

Low

CVSS overall score

This score calculates overall vulnerability severity from 0 to 10 and is based on the Common Vulnerability Scoring System (CVSS).
/ 10

CVSS v3 base metrics

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
Low

CVSS v3 base metrics

Attack vector: More severe the more the remote (logically and physically) an attacker can be in order to exploit the vulnerability.
Attack complexity: More severe for the least complex attacks.
Privileges required: More severe if no privileges are required.
User interaction: More severe when no user interaction is required.
Scope: More severe when a scope change occurs, e.g. one vulnerable component impacts resources in components beyond its security scope.
Confidentiality: More severe when loss of data confidentiality is highest, measuring the level of data access available to an unauthorized user.
Integrity: More severe when loss of data integrity is the highest, measuring the consequence of data modification possible by an unauthorized user.
Availability: More severe when the loss of impacted component availability is highest.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

CVE ID

CVE-2025-58754

Weaknesses

No CWEs

Credits